Categories Menu

Please note - We've migrated our forums to Wordpress

Users with 0 posts have been deleted, existing users will need to create a new password. Sign up or sign in here.

(Solved) Windows 8 Superguide 2nd Ed Videos do not play on Win 8.1

Home Forums Superguides (Solved) Windows 8 Superguide 2nd Ed Videos do not play on Win 8.1

This topic contains 27 replies, has 2 voices, and was last updated by  seniornetdb 5 years, 6 months ago.

Viewing 15 posts - 1 through 15 (of 28 total)
  • Author
    Posts
  • #7772

    seniornetdb
    Participant

    Hello
    We have acquired a new Windows 8 machine and I just upgraded it to 8.1. I then installed the Windows 8 Superguide Second Edition. When I click on a video (in any of the monitor size choices), a video window opens with a splash screen telling me to press play. I press play and the video window screen is cleared (goes to black) but the video never starts. The time counters are 0/0 too.
    Sure hope someone can help.
    Kind regards,
    Dan

    #8085

    mattb
    Participant

    Hi Dan,

    Sorry to hear you are having problems. That’s not normal at all I can assure you, the 2nd Edition guide was tested extensively on Windows 8.1.

    Can I ask if you are using Internet Explorer to view the content? (as per standard). Also, have you enabled ActiveX filtering? You must disable this in order for the videos to play.

    Let me know and I’ll do my best to assist you further.

    #8086

    seniornetdb
    Participant

    Thanks Matt
    The product launches the default browser which is IE. If I click on Safety, on the menu bar, I do not see ActiveX Filtering ticked in the dropdown list. Upon seeing the files were .flv type I went to Adobe and followed their links to a Microsoft KB that installs their Shockwave Flash, apparently the new way with Windows 8. It found that KB was already installed. This is at a SeniorNet learning centre so we do have other operating systems. I’ll try this disc on one of them and see what happens but I sure would like to hear if you or others have any ideas.
    Regards, Dan

    #8082

    mattb
    Participant

    Hi again,

    This is very strange indeed. I did wonder from your username if you were a SeniorNet customer. I will of course do everything I can to get to the bottom of this for you.

    Are you running any kind of security software on the PC at all?

    Can you use File explorer and browse to the installation directory for me, then look in the htdocs/support-files/SHQ sub folder? (by default the full path should be C:Program Files (x86)TWTWindows 8 Superguide 2nd Editionhtdocssupport-filesSHQ)

    In this folder, do you see several FLV files?

    #8083

    seniornetdb
    Participant

    Hi Matt
    Yes, the FLVs are in that folder. The only security software is the Microsoft Defender that come on Windows 8.

    I uninstalled it and reinstalled it and the install failed on an unable to write an apache file. I ran again as administrator and it installed o.k. (I am using a Microsoft id to login to this machine, not a local id).

    After the install I still get the same result. When you click on a monitor size to start the video the video opens to a blue screen that tells you to press play to continue. After pressing play it clears the blue screen to black and stops.

    We are able to run the Windows 7 Superguide on Windows 8.1, executing it by running StartSuperGuide.exe. Unfortunately the Windows 8 Second Edition doesn’t have this executable to try. This would seem to indicate that the flash in the browser works.

    We are able to install and run the Windows 8 Second Edition Superguide on Windows 8.0 which is on a different brand of hardware and uses a local login rather than the Microsoft login.

    Looking forward to your reply.

    Regards, Dan

    #8084

    mattb
    Participant

    Well I can’t understand why having a Microsoft account would stop it from working, there should be no difference. I will look into that though just to make 100% sure.

    When you right click on the black space where the video should be, do you see a context menu with “f4Player” at the top?

    Can you try disabling “Protected” mode, though the Superguide works just fine here with protected mode enabled. To do that, click on the gear icon in Internet Explorer then choose “Internet Options”. Click on the security tab and deselect “use protected mode”. Now restart IE and see if the problem persists.

    Please also try alternative browser. Install Firefox or Chrome and then copy and paste the page address from IE into the alternate browser and let me know what happens.

    We are able to run the Windows 7 Superguide on Windows 8.1, executing it by running StartSuperGuide.exe. Unfortunately the Windows 8 Second Edition doesn’t have this executable to try. This would seem to indicate that the flash in the browser works.

    Usually the Windows 7 Superguide doesn’t work on Windows 8.1 without a compatibility fix, so that does surprise me, again! Windows 8.1 Superguide uses the same executable, you can find it in the installation directory. When you start Windows 8.1 Superguide it runs this same exe file just via a batch script.

    #8081

    seniornetdb
    Participant

    Hi Matt
    Yes-when I right click in the black area where the video would normally be playing I get a context menu with f4player, settings, global settings and about adobe flash player 12.0.0.77…
    I tried disabling Protected Mode in IE but it made no difference.
    I installed Firefox and set it as the default browser but Superguide launches IE instead.
    The Windows 7 Superguide definitely works on 8.1 without us having done anything special.
    Just so you know. I have “restart”-ed Windows in between each thing above to make sure there wasn’t any think left in memory in between actions. I took a screen shot of the video window after you press play (the black one). I tried to attach it as a word doc and as a pdf but your site comes back with “The extension is not allowed”. Dan

    #8079

    mattb
    Participant

    It’s almost as if the player can’t find the video file, but yet we’ve verified that the video files are right there, very odd.

    I installed Firefox and set it as the default browser but Superguide launches IE instead.

    That’s correct, start the guide and then open Firefox, copy and paste the Superguide page address into the Firefox address bar ( http://127.0.0.1:4001/ ) and press Enter. The guide will then open in Firefox. Try watching the videos again here, this is just to help determine if this is an IE problem or not.

    I tried to attach it as a word doc and as a pdf but your site comes back with “The extension is not allowed”. Dan

    That’s correct there’s no need to embed the screenshot into a word document just upload it as a standard jpeg or png or gif picture file.

    #8080

    seniornetdb
    Participant

    Hi Matt
    We copied the link into Firefox and the behaviour was the same as in IE. The video window launches with an initial blue background screen with white writing that says Press Play. When the user presses play the blue is erased and replaced with black but the player then stops.
    Also we installed VLC and used it with “open with” to play the videos from File Explorer. That works fine but obviously wouldn’t for the student since the video file names are not appropriate for that purpose.
    We were restarting the machine in between tests to make sure we had a clean environment. Windows Update is current and set to automatically get updates.
    It appears it is not unique to IE since we had the problem in Firefox.
    Anything else we can try?
    Rgds, Dan

    #8077

    mattb
    Participant

    Extremely odd, I’ve not seen or heard of this behaviour on any other PC! I am going to need to collect some detailed debugging logs from you, I will prepare a tutorial on how to do that tomorrow. In the meantime please can you visit https://gokercebeci.com/dev/f4player?feature=player and tell me if you can play the sample video on that page?

    #8078

    seniornetdb
    Participant

    Hi Matt

    I was talking with a tutor who was at our learning centre and she was running some tests and IM’d me through Skype. She had some interesting results. I will try to upload the chat log from that session (txt) and a couple of screen shots.

    By the way I found out she did have a problem with the Win 7 SG on Win 8.1 and found a compatibility fix on the web and applied it. That is why the Win 7 SG worked.

    I passed on your request to go to the f4player link but she is teaching right now so I’m not sure when she will see it.

    Regards,
    Dan

    PS. the upload attachment seemed to work for the 3 jpg files but not text which I shall try to paste into here. [2:16:41 PM] SeniorNet DoubtlessBay: wow, this is really strange… I just started opening different lessons in the 8 Superguide and it looks like the first two lessons dont’work but if I start out with number 3 it does… I will check 8.1 and let you know

    [2:17:13 PM] Dan Goldsberry: This is the first edition?
    [2:17:37 PM] Dan Goldsberry: And you are doing it on the instructor machine?

    [2:17:47 PM] SeniorNet DoubtlessBay: yep…

    [2:18:15 PM] Dan Goldsberry: Does it fail the exact same way as the 2nd edition did?

    [2:20:20 PM] SeniorNet DoubtlessBay: yep… it works in 8.1 if I start with lesson 3… and so far it works with all the other ones further down. I will keep trying and see if I can get any others to fail

    [2:22:36 PM] Dan Goldsberry: So 1st edition and 2nd edition Win 8 Superguides fail on the same lesson one and lesson two videos when executed on the instructors’ machine (the only Win 8.1 machine)?

    [2:26:23 PM] SeniorNet DoubtlessBay: yes. It looks like if I click on Home (top left) and then click on the links on the right hand side of the screen (rather than the dark blue ones on the left where you see the chapter numbers) they always fail. If I click on the left hand chapter, then click ‘large screen’ they work sometimes and sometimes not… it’s not consistent. So far, clicking on the lesson links on the right panel never works but using the left panel it is intermittent

    [2:27:43 PM] Dan Goldsberry: What happens in between one working and then not working?

    [2:30:01 PM] SeniorNet DoubtlessBay: now none of them work. it’s almost as if something is getting corrupted. When they do work I don’t get the blue screen at all… the screen displayed is the one that shows the lesson (you see the tile screen or whatever screen the lesson relates to) and has the small icons at the bottom to pause, play, etc.

    [2:31:17 PM] Dan Goldsberry: Try restarting Windows and then only playing them from the left side please.

    [2:31:27 PM] SeniorNet DoubtlessBay: ok will do
    [2:50:51 PM] SeniorNet DoubtlessBay: did you get my email (lesson 3 screen shot)?
    [2:51:15 PM] SeniorNet DoubtlessBay: the screen shot is using 8.1. Very strange behaviour

    [2:51:32 PM] Dan Goldsberry: Yes but I need the image in a jpg (save in Paint)
    [2:52:20 PM] Dan Goldsberry: So this is 2nd edition on the instructor machine?

    [2:52:37 PM] SeniorNet DoubtlessBay: yep

    [2:53:49 PM] Dan Goldsberry: So, Lessons 1 and 2 don’t work from the left hand side. 3-6 do. And none of them work if initiated by clicking on the right side?

    [2:57:27 PM] SeniorNet DoubtlessBay: now they are working from both sides… I can’t really find a pattern???
    [2:57:50 PM] SeniorNet DoubtlessBay: but 1 and 2 never work from either side

    [2:58:21 PM] Dan Goldsberry: Even lesson 1 & 2 from the right side with Win 8 SG Ed2?

    [3:00:03 PM] SeniorNet DoubtlessBay: it is really inconsistent. I just tried lesson 7 and it doesn’t work from either side!?

    [3:00:59 PM] Dan Goldsberry: What else is running? Can you make sure nothing else is running?

    [3:02:17 PM] SeniorNet DoubtlessBay: I have IE running email and that is all. The only thing that is consistent is that ‘Play’ from the blue screen never does work.

    [3:04:01 PM] Dan Goldsberry: So if you have this blue initial screen in the video window and press play as it instructs it fails but sometimes when you click on the monitor selection it launches into the lession without the blue initial screen?

    [3:04:12 PM] SeniorNet DoubtlessBay: yes!

    [3:05:25 PM] Dan Goldsberry: So sometimes the blue initial screen is displayed for a given lesson and sometimes not, even when you initiate it from the same side?

    [3:05:44 PM] SeniorNet DoubtlessBay: yes

    [3:07:53 PM] Dan Goldsberry: Could you please restart the machine again and not bring up anything else and test a left initiation for lesson 1 first and then a right initiation? Then could you do the opposite for lesson 2?

    [3:08:05 PM] SeniorNet DoubtlessBay: ok
    [3:13:59 PM] SeniorNet DoubtlessBay: Lesson 1 and 2 both fail; i.e. the blue screen comes up for both from either side. It doesn’t seem to matter whether the left or right panel start is chosen. Lesson 3 works both ways… whether I start it from the left or the right
    [3:17:25 PM] SeniorNet DoubtlessBay: lessons 3-6 work from either side, lesson 7 fails from either side

    [3:18:09 PM] Dan Goldsberry: Does which side you test first for a given lesson make a difference?

    [3:18:21 PM] SeniorNet DoubtlessBay: it doesn’t seem to…

    [3:18:52 PM] Dan Goldsberry: O.K. Thanks. I will copy this to the forum.

    [3:19:33 PM] SeniorNet DoubtlessBay: it all works on Windows 8 machines which have the same IE… is it an 8.1 thing?

    [3:20:32 PM] Dan Goldsberry: And you are running the SG 2nd Ed when you are running on Windows 8 and then on Windows 8.1?

    [3:21:29 PM] SeniorNet DoubtlessBay: yes… I have installed the 8.0 and the 8.1 Superguides on the other W8 machines and they all run fine.
    [attachment=2:2yi50q8v]lesson 3 initiated from left side of 2nd Ed. Win 8 SG.jpg[/attachment:2yi50q8v][attachment=1:2yi50q8v]Before pressing play.jpg[/attachment:2yi50q8v][attachment=0:2yi50q8v]After Pressing Play.jpg[/attachment:2yi50q8v]

    #8076

    seniornetdb
    Participant

    Hi Matt
    We are not able to go to that website as siteadvisor stops us. (We use Defender and Windows Firewall but siteadvisor. com to keep students out of risky websites. See attached screen shot.
    Regards,
    Dan[attachment=0:3mzj5xdn]Siteadviser Warning.png[/attachment:3mzj5xdn]

    #8075

    mattb
    Participant

    Hi Dan,

    I wonder if Site Advisor is causing the issue then? The only other time I have seen intermittent failure of the videos on a Superguide is when using an older version of ESET Smart Security. Since the video player component is taken from that site that you cannot access (there is no risk that I am aware of) this could be causing the issue.

    There’s no difference in which page is loaded depending on how you navigate so this has to be an issue with something on those machines.

    Can you do a test for me anyway, it will help get to the bottom of this.

    1) Start Windows 8 Superguide on the problematic machine
    2) Choose a small video size and click to open the video, but don’t press play yet.
    3) Press the F12 key, an extra debugging window will appear attached to the window.
    4) Resize the window manually so that you can see the play button again (debug window will have obscured it)
    5) Use the buttons in the left hand side of the debug window to choose the console (see the picture the correct option is circled in red)
    6) Press the Play button. Several lines will appear in the debug window at the bottom.
    7) Right click on the console and choose “Copy &all”. Paste this data into your reply.

    If you need help with these instructions or something is not clear please do not hesitate to contact me again.

    #8074

    seniornetdb
    Participant

    Hi Matt

    I don’t think siteadvisor is the problem because it works some of the time and all the other SGs work on all our operating systems except the Win 8 Second Edition on the Win 8.1 machine. This is a new machine so there is not a lot of rubbish on it and since it is the Instructor machine (hooked up to hdmi video) it pretty much stays that way. ASUS craplettes and Office 2010 and 2013 are pretty much it.

    We ran the test and the first one started the java console and so on, and then failed. The test was then run purposely with a video that sometimes works and did in this case. I will copy the email from the tutor who ran the test for me below:
    Test 1
    JavaScript Console is attached and accepting commands.
    NetStatusEvent: NetConnection.Connect.Success
    NetConnection connected to null
    Play file: support-filesSHQwindows81-tutorial-1-starting.flv
    Video dimensions: 624×489
    NetConnection is: true
    Autoplay: support-filesSHQwindows81-tutorial-1-starting.flv
    NetStatusEvent: NetStream.Play.StreamNotFound

    I hope this tells him what he wants to know. I am going to use this feature to see what happens when one of them does work and will send that later too.

    Test 2
    This is what I get when it works… weird, there’s a bunch of errors there too but it seems to get around them.

    HTML1300: Navigation occurred.
    File: lesson3.php
    HTML1524: Invalid HTML5 DOCTYPE. Consider using the interoperable form “< !DOCTYPE html>“.
    File: lesson3.php, Line: 1, Column: 1
    HTML1502: Unexpected DOCTYPE. Only one DOCTYPE is allowed and it must occur before any elements.
    File: lesson3.php, Line: 30, Column: 1
    HTML1513: Extra “” tag found. Only one “” tag should exist per document.
    File: lesson3.php, Line: 31, Column: 1
    HTML1503: Unexpected start tag.
    File: lesson3.php, Line: 31, Column: 7
    HTML1512: Unmatched end tag.
    File: lesson3.php, Line: 32, Column: 1

    Please let us know if you need us to collect more info.
    Regards,
    Dan

    #8070

    mattb
    Participant

    Hi Dan,

    Unfortunately the kind of behaviour you are describing, where it works sometimes and not others, is exactly what incompatible security software causes.

    The key thing in your logs is “NetStatusEvent: NetStream.Play.StreamNotFound”. That is the player basically saying the file does not exist, yet we know it does because it plays sometimes.

    The second log seems to be from the PHP page rather than the video page, they are mostly warnings and can be ignored (more to do with the page not 100% meeting HTML5 standards). I don’t think collecting any more of the logs will yield any more useful information.

    Please could you try disabling SiteAdvisor and try again, it’s the only thing I can think that could be causing this behaviour. If that yields any positive results I have a possible workaround for you to try.

Viewing 15 posts - 1 through 15 (of 28 total)

You must be logged in to reply to this topic.

Advertisment ad adsense adlogger